Are my Intermittent UPS problems because of TLS 1.0?

UPS has said that in preparation to their December 31, 2017 upgrade to the secure communication protocol TLS 1.1 that they will be periodically switching off and on TLS 1.0.  This means that programs that do not support TLS 1.1 could have intermittent connectivity problems communicating with UPS servers.

Here’s what they have said on their website:

UPS will be making changes beginning September 1, 2017 through December 31, 2017 to support enhancing our security. During this time, you may see intermittent failures for transactions using TLS 1.0 or earlier.

Effective 12/31/2017, UPS will only accept TLS 1.1 and 1.2 security protocols. It is highly recommended that the most current version, TLS 1.2, be implemented. After that date, any communication requests submitted to UPS using older protocols (TLS 1.0 or earlier) will fail.

Symptoms

If you are running an older version of your shopping cart software your shoppers might report things such as connectivity errors for UPS or that no shipping options (for UPS) are displayed.  If you are using the ShopSite Pro Alert feature you might see messages like:

ShopSite Alert: Failure in UPS for [your store name], Tracking ID: 74e6506c-c53a-11e8
An order had an error preventing it from going through.
Module: UPS Error code: UPS Message: Could not communicate with server for shipping rates. Please contact the merchant.
(UPS) Unknown SSL protocol error in connection to onlinetools.ups.com:443 ; uplink return code: 35

Solution

The solution is to upgrade to the latest version of your eCommerce software or at least to a version that has TLS v 1.1 support.  For ShopSite you need to be running version 12 sp2 r4 or greater.  Even if you are not using UPS, other services such as payment gateways will eventually be upgrading to TLS 1.1 or 1.2 so you will most likely need to upgrade by next year.

I don’t know why UPS is doing this kind of testing during the busy holiday shopping season or why they are making the switch before the PCI deadline of June 2018.  But since they are, you should definitely make sure your cart is up to date.

For more information about TLS and why vendors are switching over, read this blog post.  For a list of some of the dates that vendors are saying they will switch over, see this kbase article.

One Comment

  1. Orem says:

    Thanks for the update, David.

Leave a Reply

ShopSite Online Shopping Cart Software On YouTubeShopSite Online Shopping Cart Software BlogShopSite Online Shopping Cart Software on Google+ShopSite Online Shopping Cart Software On TwitterShopSite Online Shopping Cart Software On FacebookQuestions?888-373-4347E-commerce Blog ShopSite's E-commerce Blog Author